Opened 3 years ago

Last modified 3 years ago

#340 new Unknown

Some results in a Kendo grid (table) are not displayed correctly when using chrome web browser

Reported by: Paul Leo Owned by:
Priority: Unknown Milestone: Unassigned
Component: View-App Version: Unknown
Severity: Unknown Keywords:
Cc:

Description (last modified by Paul Leo)

Some query results are not displayed correctly when using the latest chrome browser. The results table which uses the Kendo grid, will display rows which are not sorted correctly. If either Firefox or IE is used to run the same query, the results are displayed correctly. This issue has been reported by Tong Zheng of Utah.

The query module used for this report is:

ibisph-content\xml\query\module\mort\Trend_MortCntyICD10.xml

The configuration for this module(CrudeRate?) is being used for Trend Analysis, and the Primary Measure (first Measure listed in the query configuration) is Year.

When results display normally

If one runs the default query, the results display correctly in any browser tested, displaying the Crude Rate for each year in the 5 year group 2010 – 2014. There are also no issues when the Display-By Category is set to Year, or when values available in other Display-by variables have been filtered to one value. For example if in step 4 (Select sex) you choose Males only or Females only, and in step 6 you select Display-by sex, the results will be displayed correctly in any browser

When results are displayed incorrectly

If we choose a Display-by Variable (other than year) with more than one value, and this variable has not been filtered to display only one value, the year ordering for each category value will not display correctly when using the chrome browser.

However the same query will display correctly in Firefox or IE.

We have verified that the data being returned by IBISQ is correct by running the query application URL with sas=3. The attached files in this ticket show the results being displayed correctly in firefox and results being displayed incorrectly in chrome

How to replicate this issue

Tong has created a saved query that may be run as follows:

Place the following URL in Firefox or IE and view the results

https://ibis.health.utah.gov/query/definition/result/tzheng@utah.gov/mort_Trend_MortCntyICD10_CrudeRate_1617.html

Then place the URL in chrome, and compare results to firefox or ie

Issues with Chrome and Kendo Grid found when performing a google search We performed a google search and a similar, if not the same issue, has been discussed in the following URL:

http://stackoverflow.com/questions/39574396/kendo-grid-sorting-not-working-in-chrome

Attachments (2)

FireFox in order.JPG (170.9 KB) - added by Paul Leo 3 years ago.
Results in Firefox displayed correctly
Chrome NOT in order.JPG (174.4 KB) - added by Paul Leo 3 years ago.
Results in Chrome displayed incorrectly

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by Paul Leo

Attachment: FireFox in order.JPG added

Results in Firefox displayed correctly

Changed 3 years ago by Paul Leo

Attachment: Chrome NOT in order.JPG added

Results in Chrome displayed incorrectly

comment:1 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:2 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:3 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:4 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:5 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:6 Changed 3 years ago by Paul Leo

Description: modified (diff)

comment:7 Changed 3 years ago by Paul Leo

Description: modified (diff)
Note: See TracTickets for help on using tickets.