Opened 5 years ago

Closed 5 years ago

#268 closed Adopter Support (Invalid)

Indicator report left nav for rpts with single ind view

Reported by: Lois Haggard Owned by:
Priority: *High Milestone: Adopter Support
Component: Content Version: 2.3
Severity: Minor Effort Keywords:
Cc:

Description (last modified by Paul Leo)

The “Graphical Views” and “Interactive Views” left nav button text on the indicator view pages disappears when the indicator has only one data view, AND that view has more than one series.

We have replicated this using the core ibisph-view app.

Here is NM indicator/profile xml files for testing:

Occupation Hlth .Year Data View.xml

Occupation Hlth Main .xml

Attachments (2)

temp.png (163.9 KB) - added by Lois Haggard 5 years ago.
EMS indicator with one view and only one data series
temp2.png (150.4 KB) - added by Lois Haggard 5 years ago.
Occupational health indicator with only one view but mult series'

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Lois Haggard

Attachment: temp.png added

EMS indicator with one view and only one data series

Changed 5 years ago by Lois Haggard

Attachment: temp2.png added

Occupational health indicator with only one view but mult series'

comment:1 Changed 5 years ago by Lois Haggard

Description: modified (diff)

comment:2 Changed 5 years ago by Paul Leo

Description: modified (diff)

comment:3 Changed 5 years ago by Paul Leo

Changed URLs for indicator profile xml files to point to correct directory - due to restructuring of adopters nm repo ( actually - renamed ibisph-content to ibisph-view-content

comment:4 Changed 5 years ago by Garth Braithwaite

Component: View-AppContent
Milestone: 2.3 - DevelopmentAdopter Support
Resolution: Invalid
Severity: UnknownMinor Effort
Status: newclosed
Type: DefectAdopter Support

It appears the problem is that the XML file was not republished when migrating to the newer code? It was created almost 2 years ago and is missing the newer INDICATOR_VIEWS/INDICATOR_VIEW elements which the SS XSLT code uses. The new structure was needed so that the assoc IPV titles could be kept inside the IP XML file and thus saves having to open all assoc IPV XML files when trying to build the IPV full titles.

<PUBLISHED_DATE>09/17/2012</PUBLISHED_DATE>

For example NM's PrenCare?.xml <PUBLISHED_DATE>10/18/2013</PUBLISHED_DATE> and has the newer structure.

Note: See TracTickets for help on using tickets.