Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#258 closed Enhancement (Duplicate Ticket)

CGI 2.1 enhancements - %data_frame%, %filter_exclude%, %pass_through%, %newdataset%, %datayear%

Reported by: Tong Zheng Owned by: ZW
Priority: Unknown Milestone: Unassigned
Component: IBIS-Q Version: 2.1
Severity: Unknown Keywords: cgi enhancement
Cc: tzheng@…, garth.braithwaite@…, lois.haggard@…

Description

We requested some enhancements on ZW's backend cgi. All those enhancements are included on cgi 2.1. Basically, the 2.1 adds %data_frame%, %filter_exclude%, %pass_through%, %newdataset%, %datayear%. They make the http request url more powerful to pass the selected values to backend cgi.

For more information on how each of them functions, please go to ticket #236 attachment "the letter to zw (http://www.ibisph.org/trac/attachment/ticket/236/LettertoZWFeb2014.docx).

Please refer ticket #236 for the history and details of this ticket (http://www.ibisph.org/trac/ticket/236)

Attachments (1)

Select counties.docx (50.3 KB) - added by Tong Zheng 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by Tong Zheng

Tong has tested all parameters. The linux and Window versions of cgi 2.1 have been sent to Garth. Garth is going to check them in the repository.

Last edited 5 years ago by Tong Zheng (previous) (diff)

Changed 5 years ago by Tong Zheng

Attachment: Select counties.docx added

comment:2 Changed 5 years ago by Tong Zheng

In further testing, %data_frame% can't be filtered correctly because all values on %data_frame% list are forced in application url. See attached for detailed information. ZW is working on it.

comment:3 Changed 5 years ago by Garth Braithwaite

Owner: changed from Tong Zheng to ZW

comment:4 Changed 5 years ago by Lois Haggard

Tong found an issue with the data_frame function. It will list all counties in the results, regardless of what the user selected. So if the user filtered to 3 counties, right now, they are getting all counties in the result.

ZW is working on this. We'll try to get it into version 2.3 release, which means we'd need to get it from ZW on 10/13/2014.

comment:5 Changed 5 years ago by kathie

Resolution: Duplicate Ticket
Status: newclosed

comment:6 Changed 5 years ago by Tong Zheng

For the parameter name in xml file, please use "dataframe_dimensionName" to define complete list of the dimension. eg, "dataframe_GeoCnty" with the valude 1-29. We decided before to use dimension name only. The problem is caused by that.

Note: See TracTickets for help on using tickets.