Opened 9 years ago

Closed 8 years ago

#147 closed Issue (Fixed)

IBIS Admin "Description of Modification" text now says "bean modified by:editor_id"

Reported by: brian Owned by: Kim Neerings
Priority: -Low Milestone: 2.1 - Testing
Component: Admin-App Version: 2.1
Severity: Minor Effort Keywords:
Cc: kneerings@…

Description

In IBIS Admin 2.0 when a change is made to an Indicator the "Description of Modification" text now says "bean modified by:editor_id". Previously it would identify the change, something like "Graph Title modified by:editor_id". We would like to return to this more descriptive text.

Change History (9)

comment:1 Changed 8 years ago by Garth Braithwaite

Milestone: Unassigned2.1 - Testing
Owner: set to Testing
Version: 2.02.1

Can't replicate - could be fixed? If not need more details on how to replicate.

comment:2 Changed 8 years ago by Kim Neerings

It's not fixed. Look at demo7 on dev admin. When I opened the page, the description modification said, "List values updated by kneerings." So I made a change in the definition field, hit save, and the description modification now says, "Bean Modified By: administrator@…"

comment:3 Changed 8 years ago by Garth Braithwaite

TESTING: Once I have siteminder hooked up you will see your name. So leave the ticket open and assigned to Testing.

comment:4 Changed 8 years ago by Garth Braithwaite

Milestone: 2.1 - TestingUnassigned
Type: DefectIssue

The issue is really that the old modified description was more specific. What is being reported as a defect is the app being configed without a message value so the generic, default message is being used. This value can be specified for any save controller using the "modifiedDescriptionMessage" property via a spring config like:

<property name="modifiedDescriptionMessage" value="Indicator Important Facts modified"/>

The code then uses this specified message value as a prefix to which " by: " and the user's ID are then appended. Currently only INDICATOR and INDICATOR_VIEW have a MODIFIED_DESCRIPTION field but this value is also a property so it can be changed if a table has such a text field (which none other than the 2 above do).

TESTING: Values put into core spring xml files SVN: 3915. If want/need to see different values the save controllers bean defs need to be updated with the approp message text.

Last edited 8 years ago by Garth Braithwaite (previous) (diff)

comment:5 Changed 8 years ago by Garth Braithwaite

Owner: Testing deleted

comment:6 Changed 8 years ago by Garth Braithwaite

Milestone: Unassigned2.1 - Testing
Owner: set to Testing
Severity: UnknownMinor Effort

comment:7 Changed 8 years ago by Kim Neerings

Cc: kneerings@… added

comment:8 Changed 8 years ago by Kim Neerings

Owner: changed from Testing to Kim Neerings
Status: newassigned

comment:9 Changed 8 years ago by Kim Neerings

Resolution: Fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.